
PlViewer

A Log Analysis Tool For

PocketLOGGER Log Files

1



Contents

INTRODUCTION.......................................................................................................................................... 3

INSTALLATION............................................................................................................................................3

USING PLVIEWER....................................................................................................................................... 4

LOADING A LOG..........................................................................................................................................5

CONFIGURING THE GRAPH DISPLAY..................................................................................................8

ADDING AND REMOVING PARAMETERS ..................................................................................................................8
ADDING AND REMOVING GRAPHS..........................................................................................................................9
GRAPH SETUP................................................................................................................................................ 10
PARAMETER SETUP..........................................................................................................................................12
SENSOR SETUP................................................................................................................................................13

Double Hz Feature................................................................................................................................. 13
Wideband Sensors.................................................................................................................................. 15

OTHER DISPLAY OPTIONS.................................................................................................................... 16

LEGEND WINDOW........................................................................................................................................... 16
DATA WINDOW.............................................................................................................................................. 17

PRINTING ................................................................................................................................................... 18

PAGE SETUP...................................................................................................................................................18
PRINT PREVIEW.............................................................................................................................................. 18
PRINT............................................................................................................................................................19

SAVING IMAGES........................................................................................................................................20

2



Introduction

PlViewer is a application designed for analyzing log files generated by Digital Tuning Inc.’s
PocketLOGGER product – an automotive datalogger for Palm Computing platforms. PlViewer provides
functions for displaying the PocketLOGGER log files graphically, or in table form. It can plot scatter
graphs, save graphs as images or print them, and can also directly download log files from your PDA via a
serial link.

PlViewer is written in Java, and has been successfully tested on most Windows and Linux PC platforms.

Installation
PlViewer will not work unless you have Java installed on your computer. Java may be downloaded from
Sun's Java web site (java.sun.com). Java 2 Standard Edition (J2SE) Runtime Environment (JRE) is
recommended. 

To install PlViewer, you will need to download PlViewer.jar. to an accessible location, such as the
Desktop. Some Windows based browsers rename the file to PlViewer.zip – in this case you must rename it
back to PlViewer.jar.

On Windows systems, assuming that Java was installed successfully,  you can now run PlViewer simply by
double-clicking on the PlViewer.jar file.

On Linux systems, PlViewer can be started using the command;

java –jar PlViewer.jar

Note that when PlViewer terminates, it will create a file 'plviewer.cfg'. This file is used to store
configuration options. Removing this file will not prevent PlViewer from running, it will simply erase any
configuration options you may have set.
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Using PlViewer

When started, PlViewer will show the main window1;

Figure 1 - The main window

The application menu bar contains six drop down menus. The File menu contains options for loading and
saving log files, setting print options, and printing graphs. The Edit menu contains options for copying data
to the system clipboard. The Preferences menu contains parameter, graph and sensor configuration options.
These enable you to set up parameter colors, scaling values, etc. The Windows menu provides extra display
options for viewing the log data. The Tools menu is where most viewer extensions add utility commands
(such as the PDA download). The Help menu provides information about the current version of PlViewer.

1Note that the exact appearance of the window will vary, depending upon the operating system and window
manager.
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Loading a log
Loading log files is done via the File->Open… menu option. This will bring up a standard file ‘Open’
dialog, from which you may navigate the directory hierarchy and select the log file you wish to load.

Figure 2 - The File Open dialog

The file types drop down list displays a list of the supported file types. PlViewer currently supports pdb
format log files (files created by PocketLOGGER f), and CSV (comma separated variables) files which
have previously been saved by PlViewer.
A log file can be selected for loading by double clicking on it’s entry in the file list, or by selecting it with a
single click, and the selecting the ‘Open’ option. Selecting ‘Cancel’ will return you to the main PlViewer
window without loading a log.

After selecting a log for loading, PlViewer will return to the main application window to display the graphs.
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Figure 3 - The graph display

By left clicking on a graph, PlViewer will display a vertical line through all the graphs at the nearest sample
time. The legends will indicate the sample values for the displayed parameters and the time value below the
menu bar will display the actual time stamp of the samples.

The slider bar at the bottom of the window can be used to rapidly scroll forwards and backwards through
the sample data.

A region of a graph can be selected by pressing and holding the Shift key while clicking the left mouse
button. The toolbar will indicate the size of the selected region in seconds.

6



Figure 4 - Selecting a region
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Configuring the Graph Display

Adding and removing parameters 
PlViewer can display any number of graphs, and each graph may show as many parameters as you wish.
Changing the parameters displayed on a graph is done by using a graph’s pop-up menu. Right click on a
graph to obtain the pop-up menu, and then select the ‘parameters’ sub menu.

Figure 5 - Graph pop-up menu

The parameters submenu lists all the parameters in the current log with checkboxes. The checkboxes for
those parameters already displayed in the graph will be checked. Parameters can be added or removed by
toggling a parameters checkbox. Each time a parameter is selected, the submenu will be closed and the
graph updated.
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Adding and removing graphs
A new, empty graph can be created by using the graph button on the toolbar below the main menu.

This will create an empty graph below your existing graphs. If
the current application window is not large enough to display the
extra graph, a vertical scrollbar will appear on the right side of
the application window. This allows you to scroll down and view
the new graph.

To close a graph, use the ‘Close’ option on the graphs pop-up menu.
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Graph Setup
You can configure other properties of the graph, such as scaling values, height and colors via the ‘Graph
Setup’ option on the ‘Preferences’ menu. This will open a dialog box which contains a number of options.

Figure 7 - Graph Setup options

The Options group provides checkboxes for toggling three options;

• The ‘Legends enabled’ checkbox allows you to enable or disable to display of the parameter legends,
which are displayed above each graph. This legend shows the color of each parameter being displayed
on the graph and the sample value at the currently selected time sample.

• The ‘Seconds marks enabled’ checkbox allows you to switch off the tick marks displayed at one second
intervals along a graphs horizontal axis.

• The ‘Sample cursor enabled’ checkbox can be used to enable or disable the drawing of the time cursor
– the vertical line displayed on the graphs when you left click with the mouse.

The Scaling group provides two configurable values;

• The ‘Time/pixel ratio’ value define how many screen pixels correspond to one second on a graphs
horizontal axis. You can enter a value here directly, or use the ‘Zoom In’ and ‘Zoom Out’ options on a
graphs pop-up menu.
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• The ‘Graph height’ value defines the height of the graphs vertical axis in screen pixels.

The Colors group provides four color configuration options. By clicking on the colored rectangular button,
a color chooser dialog is displayed. This allows you to configure the colors from a selection grid, as HSB or
RGB values.

• The ‘Graph background’ color is used to paint the graph background.

• The ‘Graph axes’ color is used to draw the horizontal and vertical axes on the graphs.

• The ‘Graph selection’ color is used to draw the currently selected region of a graph (to select a region,
click-shift-drag with the left mouse button).

• The ‘Legend text’ color is used to display the parameter sample values in the graph legends (if
enabled).

Once you have configured the values, the ‘OK’ button will accept the new changes and close the Graph
Setup window. The ‘Apply’ button will accept the new values, but leave the dialog displayed. The Cancel
button will discard the changes and close the dialog.

11



Parameter Setup
Parameter configuration options, such as color and scaling values, can be accessed via the ‘Parameters’
option on the ‘Preferences’ menu. This opens up the Parameter Configuration dialog box.

Figure 8 - Parameter Setup options

This dialog displays a scrollable list of all the configured parameters2 in alphabetic order.  There are four
columns;

• The first column gives the parameter name as it is displayed in the graph legends. 

• The second column displays the parameter minimum value. This is the value of a parameter at the
bottom of a graph’s vertical axis. If no value is provided, PlViewer will use the minimum value from
the current log.

• The third column displays the parameter maximum value. This is the value of a parameter at the top of
a graph’s vertical axis. If no value is provided, PlViewer will use the maximum value from the current
log.

• The fourth column is the color used to draw the parameters sample values in a graph. By clicking on
the colored rectangular button, a color chooser dialog is displayed. This allows you to configure the
colors from a selection grid, as HSB or RGB values.

Once you have configured the values, the ‘OK’ button will accept the new changes and close the Parameter
Configuration window. The ‘Apply’ button will accept the new values, and leave the dialog displayed. The
Cancel button will discard the changes and close the dialog.

2 Some parameters will be specific to each of the DSM/OBDII versions of PocketLOGGER.
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By clicking on a parameter name in the first column, an ‘Edit Parameter’ dialog is displayed.

Figure 9 - Edit Parameter dialog

This gives you three further configuration options;

• The ‘Parameter Name’ is the display name of the parameter. This is used in PlViewer, for example, in
the legends, and in a graphs pop-up ‘Parameters’  submenu.

• The ‘Parameter Description’ is simply a brief description of the parameter.

• The ‘Aliases’ is a list of other names (aliases) that represent this parameter. These are used by the input
filters to map parameter names (for example, in a CSV log file) into the PlViewer parameters3.

Sensor Setup

Double Hz Feature
The KeyDiver ECU chip with the 'Double Hz' feature changes the way in which the airflow is reported to
the logger in order to work around the 1606Hz limit imposed by the standard ECU. To let the log viewer
know that you are using this feature, make sure the 'Double Hz' option on the 'Preferences' menu is selected.

3 Change these values with caution – it may affect PlViewer’s ability to load log files.
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Figure 10 Enabling the Double Hz feature

The viewer will make the appropriate compensation to the airflow readings in order to display it correctly.
This setting will only take affect the next time a log is loaded, it will not affect the currently loaded log.
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Wideband Sensors
PocketLOGGER supports wideband sensors connected via the EGR Temperature wire (non-California
models). PlViewer must be configured in order to correctly display the wideband sensor data. To configure
a wideband sensor, select 'Wideband...' from the 'Preferences' menu. This will open the wideband sensor
configuration dialog.

Figure 11 The Wideband sensor configuration

The 'Name' is the name that will be displayed on the log graph. In the 'Offset' field you should enter the
same value as used in the "WBo2 Setup" on the PocketLOGGER.

Checking the 'Advanced configuration' checkbox will allow you to fine tune the scale and base offset values
for the wideband sensor. Do not use this option unless you are sure you know what you are doing, as it will
alter the displayed values.

Changes to the Wideband configuration will only take effect the next time a log is loaded. It will not affect
the currently loaded log file.
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Other Display Options

Legend Window
The legend window can be displayed by selecting the ‘Legend’ option on the ‘Windows’ menu.

Figure 12 - The graph Legend

This displays the values of all the parameters in the log file at the currently selected time sample. Left
clicking on a graph to select a new time sample will cause the legend to be updated with the sample values
at the selected time.
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Data Window
The data window can be displayed by selecting the ‘Data’ option on the ‘Windows’ menu. This provides a
direct view of the log data, much like a spread sheet.

Figure 13 - The Data window displays the raw sample values

The data window allows a continuous select of one or more rows. Selected data can be copied to the system
clipboard using the 'Copy' button. Data copied into the system clipboard may be pasted into other
applications. The Copy button will be greyed out if no selection has been made. 
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Printing 
PlViewer provides options to configure and print graphs on your printer. Three print options are available
from the File menu, Page Setup, Print Preview and Print. 

Page Setup
Selecting ‘Page Setup’ from the ‘File’ menu will display the ‘Page Setup’ dialog.

Figure 14 - The Windows 'Page Setup' dialog

This provides configuration options to set the paper size, margins, orientation, etc. The exact format and
options available will vary, depending on the operating system.

Print Preview
The ‘Print Preview’ option on the ‘File’ menu gives you the opportunity to see what your printed graphs
will look like before you print them.
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Figure 15 - Previewing graphs before printing

Depending upon the number of graphs displayed and the print options, this may be split into multiple pages.
A toolbar contains a drop down list of scaling factors, allowing you to preview the graphs different sizes.
You may also enter a custom size directly, by double clicking on the current value and entering a new value.
Once you have finished with the ‘Print Preview’ dialog, select the ‘Close’ button.

Print
Selecting ‘Print’ from the ‘File’ menu will display the ‘Print’ dialog box. Depending upon the platform, this
will provide further options to configure the printer and the number of copies. To print the graphs, select the
‘OK’ button.
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Saving Images

It is possible to save the current graph(s) as an image by selecting the ‘Save Image...’ option from the ‘File’
menu. This opens up a file selection dialog which allows you to select the type of image file, and the name
under which to save it. The available imageformats will vary, depending upon the platform. Lossy images
formats, such as jpeg, are not very suitable for the graphs produced by PlViewer. The png format, which
should be available on most platforms provides good, lossless compression, and is the recommended image
format.
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